Centro risoluzione problemi

In questa sezione troverete tutte le problematiche riscontrate nel mio sistema con le varie soluzioni. Naturalmente si tratta di una pagina realizzata da poco e verranno aggiunti mano a mano tutti gli aspetti negativi che possono avere una soluzione.

ARGOMENTI:

 

  • Arduino si è disconnesso quando ho acceso un carico induttivo
  • La centralina Lab domotic 4K non da segni di vita.
  • Problema della DLL mancante, MSSTDFMT.DLL
  • Ho alimentato la scheda ma non si accende il led...bruciato integrato
  • Ho collegato i moduli relè con l' adattatore RJ ma ho un problema
  • Credo di aver bruciato un relè del modulo, non scambia più.  
  • Le sonde LABsensor nella 503 segnalano temperature non reali
  • Disconnessione Arduino con due labduino collegate

Arduino si è disconnesso quando ho acceso un carico induttivo

Fate assolutamente attenzione, l' alta tensione è molto pericolosa e può causare la morte. Non mettete mano a cose che non conoscete, al limite chiamate un' amico elettricista che sa come e dove mettere le mani. 

SOLUZIONE:

I carichi induttivi, sono spesso oggetto di  forti disturbi elettromagnetici, spikes ecc che possono generare disturbi o addirittura distruggere alcune apparecchiature elettroniche come ad esempio Arduino. Anche le bobine dei relè passo passo alimentate a 230 volt potrebbero generare dei problemi, ed ecco la soluzione. Un filtro RC formato da un condensatore e una resistenza. In commercio ci sono filtrini già pronti e si collegano semplicemente in parallelo al contatto del relè passo passo come mostrato nel disegno.

Sotto riportato il collegamento elettrico del filtro applicato ai capi della bobina di un relè, nel mio sistema, visto che in priorità impianto vengono utilizzati relè passo passo, viene da se collegare questo filtri RC o Filtri Snubber, in parallelo al contatto normalmente aperto utilizzato per il ritorno stato acceso/spento del passo passo

Un filtro RC commerciale già pronto, si acquista nel web a pochi euro oppue è possibile costruirlo, bastano anche solo il condensatore e la resistenza


La centralina Lab domotic 4K non da segni di vita.

Le cause che possono portare a non fare accendere i relè della scheda labdomotic 4000 possono essere diverse:

Prima cosa assicuriamoci che il modulo a relè sia connesso alla centralina e che abbia il led del' alimentazione 12 volt, acceso. La centralina di per se non ha niente che possa mostrare se il comando è stato ricevuto ed inviato quindi, dobbiamo avere il modulo come riferimento, accesso e connesso.

 

Altro aspetto potrebbe essere che il Sistema operativo non abbia riconosciuto il driver perchè non è presente una DLL nel sistema. Per questo problema, andate alla "risoluzione della DLL mancante".

 

Se la scheda è stata riconosciuta e il driver è stato installato, allora è probabile che, se non state usando il software Domotica Tartaglia PRO 3 che crea in automatico i file di lancio, non sia stata installata la cartella apposita con dentro i file per la gestione della scheda. Dovete scaricare il file Hardware start e posizionare la cartella "Labdomotic 4000" in C:/

 

Scarica il file qua

Scompattate il file rar compresso e posizionate la cartella "Labdomotic 4000" nel percorso C:/

Dovete avere la cartella "Hardware" al' interno di "Labdomotic 4000" dove sono presenti i file exe e la DLL di comando.

Se non vedete le cartelle, significa che state usando una vecchia versione di Win rar oppure un programma di decompressione dati sbagliato. Utilizzate Winrar per non avere problemi.


Problema della DLL mancante, MSSTDFMT.DLL

Ogni tanto, su alcuni sistemi operativi (Vista, Seven, Windows 8) attraverso il comando di accensione relè inviato da uno dei miei Software, Appare un messaggio di errore di una dll mancante. Il problema riguarda una dll non presente nel sistema operativo oppure danneggiata. La procedura è estremamente semplice:

Per prima cosa dovete scaricare questa DLL per poi essere copiata in C:\Windows\System 32

(Se il file non fosse più disponibile, cercatelo su google oppure chiedete a me)

Se trovate problemi, contattatemi

Il file DLL si trova al seguente link Download DLL MSSTDFMT.DLL

Oppure andate direttamente a questa pagina e seguite la procedura di riparazione : Link pagina


Ho alimentato la scheda ma non si accende il led...bruciato integrato

Attenzione, la scheda non ha il diodo per la protezione sul' inversione della polarità quindi, se vi accorgete che il led non si accende, staccate immediatamente l' alimentazione alla scheda e non l' alimentatore alla presa elettrica. Se invertire l' alimentazione, tutti gli elementi ad essi connessi, come i due integrati ecc, si bruceranno in modo irreparabile e potete anche bruciare la pista del circuito stampato riferita al' alimentazione. Assicuratevi prima di collegare l' alimentatore alla presa di corrente, che l' alimentazione + e - siano corretta.


Ho collegato i moduli relè con l' adattatore RJ45 ma ho un problema

Fate attenzione perché l' adattatore rj45, richiede dei cavi Lan realizzati secondo un determinato schema e quelli attualmente in commercio con connessione pin ti pin non sono compatibili. Se collegate l' adattatore con due cavi lan da 8 conduttori cadauno, non farete nessun danno al modulo relè, ma il sistema non funzionerà. Dovete collegare i cavi come mostrato in foto ed effettuare una intestazione come mostrato nella foto sottostante.

Nel' immagine sottostante vediamo il collegamento con intestazione standard su un connettore mentre nel' lato opposto, dobbiamo configurarlo come da schema. Se uno o più relè non dovessero accendersi dovete rivedere il connettore che non sia cablato in modo errato oppure che sia stato crimpato male.


Credo di aver bruciato un relè del modulo, non scambia più.

FATE MOLTA ATTENZIONE a quello che collegate su quel contatto del relè. Solitamente un relè può fare il "click" quando viene alimentato, ma non significa che il contatto faccia lo scambio se da quel contatto è stata fatta passare una corrente troppo elevata e lo ha "saldato" in modo permanente. Se dovete collegare al relè un carico induttivo come un motore elettrico di una tapparella motorizzata, viene da se collegare un fusibile dimensionato per il carico applicato. Questo per molti aspetti: Primo perchè protegge il relè del modulo e secondo per evitare che venga danneggiata la pista del circuito del modulo stesso. Il fusibile non è necessario se il contatto del relè viene messo in parallelo al relè passo passo per il collegamento delle luci. Sarebbe meglio se per ogni relè ne venisse collegato uno, ma in alcuni casi è veramente poco necessario. Aggiungo che, in fase di installazione, dei fusibili volanti messi momentanei non farebbero male visto che, se si dovesse presentare un corto circuito, la corrente di corto, se passata dal contatto, fa veramente dei danni irreversibili al modulo relè e non solo.


Le sonde LABsensor nella 503 segnalano temperature non reali

I moduletti Labsensor per la lettura della temperatura e umidità, sono molto precisi ed affidabili ma solo se installati in ambienti aperti dove sono a contatto diretto con la temperatura ambiente. Se vengono installati dentro una scatola 503, potrebbero presentare alcuni imprevisti di facile rimedio. Solitamente questi moduletti analizzano la temperatura dalla parte frontale del tappo cieco, ma purtroppo  anche quella che arriva da dietro attraverso i corrugati. I corrugati stessi fanno entrare aria che proviene dal' esterno e questo potrebbe influire sulla lettura finale. Specialmente di inverno quando fuori ci sono temperature negative. Per ovviare a questo imprevisto, basta applicare della lana di roccia che funziona da isolante termico. Ne basta poca oppure chiudere il corrugato con un panno o altro materiale che si adatta bene a questo impiego. La migliore soluzione resta la lana di roccia, ma le soluzioni alternative sono tante.

Uno scatolotto aperto con il sensore Labsensor installato. Vedete lo scatolotto incassato a parete da dove escono i cavi? è li che bisogna intervenire con la lana di roccia. Isolate bene e la lettura della temperatura risulterà quella reale 


Disconnessione Arduino con due Labduino collegate

A volte puo capitare che Arduino perda la comunicazione con il Software quando abbiamo due schede ingressi Labduino da 48+48 collegate tra loro a grandi distanze. Per avviare a questo inconveniente, è necessario utilizzare una particolare configurazione :

 

 

schema presto disponibile